项目技术框架使用了 springboot1.5.9+mybatis+druid数据库连接池+mysql

    现在由于一些原因,决定把springboot升级到2.0.5

    在升级过程中出现了一些问题,现在记录如下:

    1,拦截器的失效,原来的类,攺为使用 WebMvcConfigurer

    2,thymeleaf-extras-shiro 版本需要升级到2.0.0

    3,原来thymeleaf中的一些写法比如 <texarea />会突然页面解析不完全,需要全部攺为<texarea></texarea>

     

    联系QQ:343886028 --加QQ群 145315854